Uploaded image for project: 'Fluid Infusion'
  1. Fluid Infusion
  2. FLUID-6583

Syllabification doesn't appear to detect content that's in the DOM but initially hidden

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Prefs Framework
    • Labels:
      None

      Description

      While integrating UIO for the community-led co-design kit, I noticed that the Syllabification adjuster doesn't apply to content which is present in the DOM on page load but initially hidden. This can be observed on the We Count site:

      https://wecount.inclusivedesign.ca/views/

      When the "Search Filters" section is toggled via the downwards chevron button on the right, none of the available filters are broken up into syllables.

      Based on my reading of https://issues.fluidproject.org/browse/FLUID-6554 it sounds like the syllabifier looks for new nodes added via a mutation observer. It doesn't seem to find and syllabify existing nodes which are hidden (via CSS display: none or the HTML hidden attribute).

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            greatislander Ned Zimmerman
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: