Uploaded image for project: 'Fluid Infusion'
  1. Fluid Infusion
  2. FLUID-5480

Naming of top-level options "inputPath" and "defaultOutputPath" in valueMapper are inconsistent and confusing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      We need to standardise on a symmetric convention for this. Similar to the situation with "input" and "value" in the standard transforms, we have ended up with a system which is inconsistent since the names used cannot be directly predicted for the inverse of the same transform. We should probably rename "inputPath" to "defaultInputPath". This actually caused a bug in the inverse transform which affected the FLUID-5479 work

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kaspermarkus Kasper Galschiot Markus
              Reporter:
              antranig Antranig Basman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: